用于angular2项目开发的vim环境配置及插件

可用于ng2开发的IDE评比

intellij idea ce 2016.1.1

  • 语法编辑 差
    • html/css emmet支持,默认补全<>
    • es6 完全不支持ES6,安装es6插件无效
    • ng2 完全不支持angular2
  • 项目特性 差
    • Rafactor 无法识别任何关联文件、命名、变量
  • 辅助工具 差

WebStorm 2016.2.1

  • 语法编辑 较好
    • html/css emmet支持,默认补全<>
  • 项目特性 较好
    • Rafactor 无法识别任何关联文件、命名、变量
  • 辅助工具 较好
    • gulp 小工具
    • RESTful Client 小工具

用于开发angular2的vim环境配置及插件

参考 http://cnodejs.org/topic/55fe3254272b724e5efefb26

https://github.com/isRuslan/vim-es6

微信扫一扫交流

作者:ryanemax
微信关注:ryanemax (刘雨飏)
本文出处:https://futurestack.cn/cookbook/frontend/ng2-vim/
授权协议: CC BY-SA 4.0